Skype for Business: WebRTC Fails to Respond to Inbound and Outbound Calls
Symptom
With the WebRTC option enabled () in the 8x8 Skype for Business Integration, the 8x8 communication panel does not respond when attempting to initiate an outbound call, or when an inbound call is made to the logged-in phone extension.
Applies To
- 8x8 Skype for Business Integration
- WebRTC
Cause
This problem happens when the logged-in 8x8 phone extension is assigned to an Account Manager-based platform account.
Resolution
Only 8x8 Admin Console-based phone extensions are supported for WebRTC in the integration.
Support for the legacy Account Manager platform is not in development, because it is scheduled to be retired. All customers will eventually be migrated to the Admin Console platform.
Note that with WebRTC disabled (
) in the communication panel, 8x8 Work phone extensions on both the Account Manager and Admin Console platforms are supported.