8x8 Work Integrations: Clicking Accept does not answer a call in the Desktop and Mobile apps
Symptom
When clicking the green Accept button in the 8x8 Work integration to answer a call, calls appear to be actively connected in the 8x8 communication panel, but the call is not active in either the 8x8 Work for Desktop or 8x8 Work for Mobile applications.
In this case, a message stating Active call on another device will also appear in a green banner in both 8x8 Work for Desktop or 8x8 Work for Mobile applications.
Applies To
- All 8x8 Work CRM integrations, v3.1 (Maestro)
Cause
By design, the Accept button in all 8x8 Work integrations only operates an attached desk phone, forcing that device to pick up calls.
8x8 Work for Desktop and 8x8 Work for Mobile will not automatically answer calls initiated through the communication panel's Accept button.
Resolution
To answer calls in 8x8 Work for Desktop or 8x8 Work for Mobile, all calls must be directly answered in those applications.
Important:
- If you do not have a physical desk phone assigned to your 8x8 extension, and you click the Accept
button, the 8x8 communication panel will stop displaying call activity. 8x8 Work for Desktop and 8x8 Work for Mobile will continue to ring until the call is answered, or until the "No answer" timeout limit has been reached.
- If by mistake a call is picked up on a desk phone using the Accept
button, simply click Flip call or dial *88 from your desired app to immediately transfer the call to that app.