8x8 Work for Salesforce: Integration comm panel displays only "launch"
Symptom
When a Salesforce user launches the 8x8 Work for Salesforce integration, the communication panel displays only the word launch instead of presenting a login prompt or appearing with the user logged in.
Important: In Salesforce Classic mode, the word launch will appear in the sidebar area when the 8x8 integration version 3.1 (Maestro) is installed.
This integration version uses a permanently floating communication panel in Salesforce Classic, and requires a CTI place-holder in the sidebar, so this does not indicate a problem.
Applies To
- 8x8 Work for Salesforce integration versions 2.8 and 3.1
Cause
The user has blocked the use of third-party cookies in their web browser.
Resolution
8x8 integrations are third-party applications that operate from and communicate with your Salesforce org, so they require the placement of cookies in your browser session to operate.
To resolve this issue in Google Chrome:
- Either enable the use of third-party cookies in your web browser, in general.
- For Google Chrome, this option is located in Settings > Privacy and security > Cookies and other site data > General settings. You can also navigate to chrome://settings/cookies.
- Or allow the use of third-party cookies for the integration itself:
- Click on the crossed-out eye icon in the floating 8x8 comm panel's address line, or in the Salesforce browser tab's address line.
- Click on Site not working?
- Click Allow Cookies.
- Close and re-open the communication panel if it does not automatically reload.
You should now see the 8x8 login prompt, or if your service is configured to use SSO login, you should be automatically logged in.