Click to Dial Fails from Contacts Page in Salesforce Intergration
Symptom
When users click to dial a phone number from an account's Related Contacts page in Salesforce Lightning mode, the 8x8 Work for Salesforce communication panel briefly responds, but no phone call is initiated.
Applies To
- 8x8 Work for Salesforce Integration v2.8
- Salesforce Lightning mode
- Salesforce Account Related Contacts
Cause
The version 2.8 integration is not designed for click to dial functionality on this specific Salesforce Lightning page.
This issue only occurs in the very specific circumstance when all of the following are true:
- 8x8 Work for Salesforce Integration version 2.8 is installed in Salesforce.
- The affected user is working in Salesforce Lightning mode.
- In Salesforce, Setup > Account Settings > Allow users to relate a contact to multiple accounts is enabled and the option properly configured.
- The user navigates to an Account's Related Contacts page, and clicks on a phone number to make an outbound call.
Resolution
At this time the resolution to this issue is:
- Click on the related contact and then click the desired phone number.
- Or, install and use the 8x8 Work for Salesforce integration version 3.1, which does not experience this problem.