Privileges Error Appears in the 8x8 Work for Salesforce Integration
Symptom
A Salesforce admin logs into Salesforce as another user, the 8x8 Work integration communication panel does not appear, and the following error is displayed:
- Insufficient Privileges
You do not have the level of access necessary to perform the operation you requested. Please contact the owner of the record or your administrator if access is necessary. For more information, see Insufficient Privileges Errors.
Applies To
- 8x8 Work for Salesforce Integration versions 2.8 and 3.1
- Salesforce Classic and Lightning modes
Cause
This issue is caused when:
- The 8x8 Work for Salesforce Integration versions 2.8 is installed in Salesforce.
- The user is assigned to the 8x8 Work Integration call center, and the variable Enable Salesforce SSO set to true.
- A Salesforce administrator logs in as the user through Setup > Manage Users > Users.
OR:
- The 8x8 Work for Salesforce Integration versions 3.1 is installed in Salesforce.
- The user is assigned to the 8x8 Work for Salesforce Integration call center, with or without SSO enabled.
- A Salesforce administrator logs in as the user through Setup > Manage Users > Users.
Resolution
The 8x8 Work for Salesforce Integrations are not designed to allow for this kind of administrative login. There are no current plans to address this issue.
In this case, administrators should test their own logins to the 8x8 integrations, and allow users to confirm this functionality on their own logins.