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8x8 Support

Voice for Teams: AADSTS50105: The signed in user is not assigned to a role for the application

Symptom

When an administrator attempts to accept an emailed invitation to access the 8x8 Voice for Teams admin portal, they receive an Error Processing Login message, and cannot log into the portal.

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Applies To

  • 8x8 Voice for Teams Admin Portal
  • Microsoft Teams
  • Microsoft Azure

Cause

This specific error is caused by user access configuration of the 8x8 Voice for Teams application in Microsoft Azure.

Resolution

There are two basic solutions in Azure:

Add the affected user(s) to the 8x8 Voice for Teams application

From an administrator perspective, this is more work but ultimately more secure since it relies on per-user access control of the application.

  1. Log into the Azure Active Directory admin center.
  2. Navigate to Enterprise Applications > All applications and click on 8x8 Voice for Teams.

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The following settings may already be applied:

  1. In 8x8 Voice for TeamsManageProperties:
    • Set Enabled for users to sign in? to Yes.
    • Set User assignment required? to Yes.
  2. Click Save if you've made any changes.

Note: Set Visible to users? to No if you don't want users to see the 8x8 Voice for Teams app in their Microsoft 365 apps list.

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Now from the same app location, assign the users who require access to the 8x8 Voice for Teams admin portal:

  1. Navigate to 8x8 Voice for TeamsManage > Users and groups.
  2. Click Add user.

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  1. In Users and groups, click on the required users to select them, then click Select, and Assign.

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Your user(s) should now appear in the application access list.

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  1. Finally, the affected user must return to their 8x8 Voice for Teams Account invitation email and click Accept Invitation to complete the process and log into the 8x8 Voice for Teams admin portal.

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Disable the 8x8 Voice for Teams user assignment requirement

This process is more direct and quick to implement than the process above.

Keep in mind that even if users can see the 8x8 application in their Microsoft 365 apps list, they cannot access the portal until they receive an invitation sent from the 8x8 Voice for Teams admin portal.

  1. Log into the Azure Active Directory admin center.
  2. Navigate to Enterprise Applications > All applications and click on 8x8 Voice for Teams.

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  1. In 8x8 Voice for TeamsManageProperties:
    • Ensure that Enabled for users to sign in? is set to Yes.
    • Set User assignment required? to No.
  2. Click Save to complete the change.

Note: Set Visible to users? to No if you don't want users to see the 8x8 Voice for Teams app in their Microsoft 365 apps list.

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  1. Finally, the affected user must return to their 8x8 Voice for Teams Account invitation email and click Accept Invitation to complete the process and log into the 8x8 Voice for Teams admin portal.

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