Voice for Teams: Sync Error: missing data: SIPUserName,SIPPassword
Symptom
When you attempt to perform a Teams sync in the Voice for Teams admin portal, the sync fails and the sync history log reports the following error:
ERROR: Failed to activate user XXX: missing data: SIPUserName,SIPPassword
Applies To
- 8x8 Voice for Microsoft Teams
- Microsoft Teams
- Voice for Microsoft Teams Admin Portal
Cause
There may have been an 8x8 user profile synchronization issue when the MS Teams integration license was enabled for that user in the 8x8 Admin Console.
Resolution
This process most often resolves this specific issue:
- Open the 8x8 Admin Console as an administrator.
- For each user reported with this issue in the Voice for Teams sync log, navigate to Home > Users, locate the affected user, and click the Edit / pencil icon
of that user to edit their profile.
- Scroll down to Services and permissions.
- Click the Enable MS Teams integration slider to disable the license
(gray).
- Click Save at the bottom of the page.
- Click the Enable MS Teams integration slider again to re-enable the license
(blue).
- Click Save again at the bottom of the page.
- Repeat the above process as needed for all other affected users.
- Finally, return to the 8x8 Voice for Teams admin portal and click Sync Now to perform another full 8x8 / Teams sync.
- Once the sync is completed, click the Sync Now dropdown arrow and click Show Sync History.
- Locate the most recent 8x8 PBX sync log in the history, and confirm that the sync was successful. The sync log should now show that the user(s) have been activated.