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8x8 Support

Inbound Calls Through Main Number Show Caller ID as Admin’s Name

Symptom

Calls that come through the Main Number show the Caller ID as coming from the Administrator's name. 

Example:

  1. A Virtual Number is pointed to a Ring Group.
  2. A call comes through the Main Number and reaches the Ring Group. 
  3. A member in the Ring Group sees the Caller ID as the Administrator's name including Ring Group Caller ID info.

Applies To

  • 8x8 Admin Console
  • Caller ID

Resolution

Check the User Profile of the Administrator whose name is showing in the Caller ID and make sure the Main Number is not saved under the Personal Contact Number field.

Personal Contact Number Field.png

It is recommended that the Primary Admin not have a phone license assigned to avoid issues with Caller ID.

Cause

Administrator's profile has the Personal Contact Number field saved with the Main Number, which results in Caller ID showing as the Administrator's name.