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8x8 Support

Internal Caller ID Displays With Call Using Deskphone to an External Number

Symptom

Make an outbound call from 8x8 Work Desktop using Call Using Deskphone to an external number.

The callee sees the Internal call ID or "Caller Name" instead of External call ID configured in the 8x8 user's profile in the Admin Console.

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Applies To

  • 8x8 Work Desktop 
  • Call using Deskphone

Cause

This is a limitation of Call using deskphone.

  • 8x8 Work Desktop with "Call using Deskphone" uses "ClickToDial" in the background.
  • ClickToDial does not have the attribute "External Caller ID".
  • ClickToDial gets the caller ID name from the "subject" which 8x8 Work Desktop gets from the Admin Console user profile.
  • If the subject is null, then ClickToDial uses the Caller Name.
  • "Call using Deskphone" the desk phone is not able to provide the "subject". Resulting in using Caller Name.
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