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8x8 Support

I can't upgrade to the latest version of 8x8 Work for Desktop

Symptom

When a new version of the 8x8 Work for Desktop app becomes available, my app does not immediately auto-update the same day. If I try using the Check for updates option, I am either provided with the previous version, or I see a message that I am already up to date.

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Can't see the Check for updates option in Work for Desktop? Click here to learn why.

Applies To

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Note: This information does not apply to users whose companies manage their software updates.

Resolution

In-app updates to the Work for Desktop application are rolled out gradually through our installed user base. Users can either:

  1. Simply wait for the prompt to update. Barring any issues, new version rollouts typically complete within one week.
  2. Manually download and install the latest version from the page Download Work for Desktop.

Migrated Users

Customers that were migrated from our previous platform, known as Account Manager, before migrating to Admin Console may have opted in to block auto updates. Contact support to find out if you are on this list.

If the current software level is end of life and does not allow your company's users to log in, then you will need to manually update these versions to a newer supported version of the 8x8 software as these can no longer be auto-updated.

Cause

Beginning with Work for Desktop v 7.3, in-app distribution of new releases is handled in a controlled and gradual manner, over the course of one week. This allows 8x8 to better manage the process and ensure the best user experience.