Skip to main content
 
8x8 Support

SMS Campaign Registration: Incorrect Tax info causes Brand rejection

Symptom

There are a number of possible reasons that the SMS > Your Brand form submission in 8x8 Admin Console can be rejected.

This article addresses issues with submission of incorrect business tax information in the required Your Brand form.

Applies To

  • SMS Campaign Registration
  • 8x8 Admin Console
  • Your Brand

Cause

One of the most common reasons for Brand verification to be rejected is due to incorrect matching of a combination of the following fields:

  • Business Name
  • Business Type
  • EIN
  • Address
Note-Icon.png Note: When submitting the Your Brand form, validation happens behind the scenes via The Campaign Registry and the IRS. 8x8 only passes the provided information on, so we cannot perform corrections to any of the submitted info.

clipboard_ef804969872db1bb26bde7c8284e6e3a0.png

Resolution

If your business is struggling to pass the Brand verification, please locate your business EIN/Tax ID confirmation document from the IRS/Government agencies, and make sure to correctly match everything when completing the Your Brand form.

As an example, the image below shows how each piece of information would need to be entered into the Your Brand registration page:

  • Legal company name: Artemisia Bath & Fixtures LLC Adele Vance Manager
  • Tax Number/ID/EIN: 999999999
  • Brand Address: 1234 Main Street Everycity CA 99999-0000

clipboard_ed1ee8431081eab2d4647ad1b7ea43077.png

Common Mistakes

  • Company Name: The most common mistakes happen with the legal company name, since everything above the address (as shown above) is considered part of your business name. It’s common to leave out the second portion of it, if one exists.
  • Business Address: Another common mistake is in how the business address is entered. Minor formatting changes such as replacing the word Street with ST can cause verification to fail.

Canadian Customers

Please provide Provincial or Federal Corporation/Registry ID Numbers (Private Profit, Public Profit)

We can automatically verify either provincial OR federal Corporation/Registry ID Numbers.  These are the identification numbers created when a business is initially formed and registered in their home province or with Corporations Canada as a federal corporation (these are not the same as the Canada federal business number, which is created for taxation purposes).  We find that sometimes the provinces have made changes over the years, and that can cause a mismatch between the original filing and currently posted information. We may need to resolve such exceptions manually with the aid of your official registration documents. 

Please avoid providing Canadian Federal Business Numbers (BN) and Canadian Revenue Agency Tax Account Numbers

We are currently unable to automatically verify, and sometimes also cannot manually verify the “Business Number,” which is the federal tax ID number.  We also cannot currently automatically verify the CRA tax account number, which is the BN with an added suffix.  Of course, if this is the only identifier available, please provide it and expect to undergo External Vetting so we can resolve via manual methods.

Canada Government and Non-Profit Society

The only Canadian non-profits that should register using the “Nonprofit” entity type are charitable organizations registered with and recognized as a 501(c) organization by the US IRS.  Such organizations must submit their US EIN and specify “Tax ID Country” as “US.” Canadian Government entities and Non-Profit Societies must be submitted using the “Private Profit” entity type and will require External Vetting as there is currently no automated path to verify them.

Legal Name:

Please ensure that the legal name you submit matches the name associated with the identification number you provide.

Non-US Entities

For non-US entities, you'll need to look at the country equivalent of the IRS document mentioned above, and match your business information in a similar manner.

What should I do if my Brand submission fails, but the information I submitted is 100% correct?

In this case, please reach out to 8x8 Support and provide a copy of your IRS EIN confirmation documentation as proof. We can then apply for additional vetting in The Campaign Registry.