8x8 Contact Center Custom CRM Is Not Loading
Symptom
8x8 Contact Center with Custom CRM Front Office Solutions.
- Login Contact Center agent console works.
- Front Office Solutions login dialog opens in VCC.
- Entering valid login for Front Office Solutions does not login, and there is no error message.
Issue is only when using Chrome browser.
Applies To
- 8x8 Contact Center Agent Console.
- 8x8 Contact Center configured with custom CRM Front Office Solutions
- 8x8 Contact Center Integration is not set to "Open new window for screenpop"
Resolution
Workaround: Change the Chrome flag to disable "same-site-by-default-cookies".
- In the Chrome browser.
- In the address bar enter: chrome://flags
- The Chrome flags list opens.
- Change: "SameSite by default cookies" to "Disabled".
Cause
Chrome browser has specific requirements for browser cookies.
Additional Information
More details can be found here: https://www.chromium.org/updates/same-site
See the section: Sept 30, 2019.