Chat Script Does Not Forward to Correct Queue Despite Correct Variable Input
Symptom
When the script has a Test Variable item with a user-defined condition (example: _department), users will be requested to input certain information, that, if matching the condition, will determine what queue the transaction will be routed to. Routing to the correct queue doesn't happen, despite users responding with words or phrases that match the condition set by the variable.
Applies To
- Contact Center
- Scripts
Resolution
Open the script and edit the Test Variable object. Verify that condition uses contains and that the content is correctly written and does not contain any extra spaces or characters. Example of incorrect settings:
Expression Preview : _department Contains "Technical Support "
Cause
Extra characters or misspellings in the Expression window.
Additional Information
More information on script variables is available in Chat Script Variables.