Campaign Manager Internal Issue Error Caused by Outbound Setup CRM Object Enabled for Field That Does Not Exist
Symptom
Campaign Manager Internal Issue Error shows when attempting to run a campaign
Applies To
- Contact Center Campaigns
Resolution
- Log in to Contact Center Configuration Manager for Contact Center.
- Go to the Outbound Setup, CRM Objects page.
- Check which CRM fields are enabled in the outbound setup.
- Go to the CRM > Fields page.
- Check that all of the CRM fields that are enabled in the outbound setup exist.
- If you find any that are enabled in the outbound setup that do not exist in the CRM Fields:
- Go to the Outbound Setup, CRM Objects page.
- Remove the field(s) that does not exist from the outbound setup.
- Click Apply.
- Go to the Campaigns page.
- Start the campaign.
Cause
A CRM field that has been enabled in the CRM objects page does not exist.
Additional Information
Campaign Manager Internal Issue Error is a generic error and may show due to other causes.