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Campaign Manager Internal Issue Error Caused by Outbound Setup CRM Object Enabled for Field That Does Not Exist

Symptom

Campaign Manager Internal Issue Error shows when attempting to run a campaign

Applies To

  • Contact Center Campaigns

Resolution

  1. Log in to Contact Center Configuration Manager for Contact Center.
  2. Go to the Outbound Setup, CRM Objects page.
  3. Check which CRM fields are enabled in the outbound setup.
    Configuration Manager outbound setup CRM objects name in CRM.png
  4. Go to the CRM > Fields page.
  5. Check that all of the CRM fields that are enabled in the outbound setup exist.
    Configuration Manager crm field names.png
  6. If you find any that are enabled in the outbound setup that do not exist in the CRM Fields:
    • Go to the Outbound Setup, CRM Objects page.
    • Remove the field(s) that does not exist from the outbound setup.
    • Click Apply.
  7. Go to the Campaigns page.
  8. Start the campaign.

Cause

A CRM field that has been enabled in the CRM objects page does not exist.

Additional Information

Campaign Manager Internal Issue Error is a generic error and may show due to other causes.