Skip to main content
TLS Upgrade
8x8 Support

TLS Upgrade

 

Question

What changes are happening in relation to TLS and Contact Center?

Applies To

  • Contact Center

Answer

To ensure the utmost security as you use your 8x8 services, the 8x8 Contact Center Configuration Manager, Agent Console, along with API calls to these systems, will require up-to-date web browsers or libraries compliant with TLS 1.2 or better:

The following browsers have been verified by 8x8 QA to support the changes occurring:

  • Google Chrome version 70 or later
  • Mozilla Firefox version 48 or later
  • Microsoft Internet Explorer 11 on Windows 10
  • Microsoft Edge (any)
  • Apple Safari version 9 or later

You can also click here to test your current browser’s security standard compatibility.

To maintain uninterrupted access for yourself, users, and APIs, please update your web browsers or SSL libraries to the latest available versions as soon as possible. Attempts to access 8x8 web portals on a computer without a TLS 1.2+ compliant browser or SSL library will prevent you from being able to reach or configure your services.

If your organization is utilizing any customization through the use of APIs in the 8x8 Contact Center, please check with your system administrators or developers to ensure that the system (SSL) libraries are updated to support TLS 1.2 or better.  Affected products may include (but are not limited to) older distributions of Linux-based operating systems (using old versions of OpenSSL) or Java Runtime Environments (JRE) older than 1.8.

 

List of supported ciphers

Priority, Cipher Name
1, TLS1.3-AES128-GCM-SHA256
2, TLS1.3-AES256-GCM-SHA384
3, TLS1.2-ECDHE-ECDSA-AES256-SHA384
4, TLS1.2-ECDHE-ECDSA-AES256-GCM-SHA384
5, TLS1-ECDHE-ECDSA-AES256-SHA
6, TLS1.2-DHE-RSA-AES256-GCM-SHA384
7, TLS1.2-ECDHE-ECDSA-AES128-GCM-SHA256
8, TLS1.2-ECDHE-RSA-AES256-GCM-SHA384

Additional Information