Skip to main content
Unable to Connect Securely / Page Can't Be Displayed error in 8x8 Contact Center
8x8 Support

Unable to Connect Securely / Page Can't Be Displayed error in 8x8 Contact Center

 

Symptom

When attempting to access your browser-based 8x8 Contact Center services such as Configuration Manager or Agent Console, you receive an error such as:

  • Unable to connect securely
  • Can't connect securely
  • This page can't be displayed

tls-error.png

Applies To

  • 8x8 VCC Configuration Manager
  • 8x8 Contact Center Agent Console
  • All 8x8 Contact Center-related services accessed via web browser

Resolution

Ensure that you have the most up-to-date version of any browser you use to connect to the internet.  Browser updates contain the latest security settings, which allow you to access your browser-based 8x8 services securely.

Cause

This occurs when users attempt to access 8x8 browser-based services on older web browsers employing TLS 1.0. 8x8 browser-based services require TLS 1.2 or later.

Additional Information

 

  • Was this article helpful?