Skip to main content
Unable to add records to a started dynamic campaign, 400 Bad Request, Operation invalid on a non started campaign
8x8 Support

Unable to add records to a started dynamic campaign, 400 Bad Request, Operation invalid on a non started campaign

 

Symptom

Unable to add records to a started dynamic campaign. When attempting to add a record to the campaign via API it responds with 400 Bad Request

{
    "message": "Operation invalid on a non started campaign."
}

Applies To

  • Contact Center dynamic campaign, that:
    • Have been started
    • Contain no records

Resolution

  1. Create a new campaign in Contact Center Configuration Manager
  2. Ensure a record is added to the campaign using the filter

CC new Campaign search records returned by filter.png

  1. Start the campaign

Cause

The dynamic campaign was started without any records added using the filter in Configuration Manager

Additional Information

Identifying the issue in Configuration Manager

The campaign shows the status manual start in Configuration Manager and only has the control option to stop the campaign.

CC Campaign manual started.png

Selecting the edit option and looking testing the selected search indicates The test passed. The number of records returned by the filter is 0.

CC campaign search 0.png

 

Identifying the issue in API responses

Getting the status of the campaign will show there are no records in the campaign

GET 'https://vcc-{cluster}.8x8.com/api/stats/campaigns/{campaign-id}.json'

     {
    "campaign": {
        "campaign-name": "FalseStart",
        "campaign-id": 481,
        "enabled": "Y",
        "status": 1,
        "no-of-records": "",
        "caller-id": ************,
        "queue-id": 137,
        "start-time": "",
        "end-time": "",
        "actual-run-time": "",
        "actual-stop-time": "",
        "daily-start-time": "",
        "daily-end-time": "",
        "retry-interval": 120,
        "max-retry": 1,
        "abandon-max-retry": "",
        "max-ring-time": 15,
        "integration-type": "contactual",
        "calling-window": 0,
        "schedule-name": "null",
        "timezone": "",
        "dynamic-campaign": "Y",
        "sequential": "N"
    }
}

Attempting to Pause the campaign responds 200 OK, however, the campaign status will not change

PATCH 'https://vcc-{cluster}.8x8.com/api/tstats/campaigns/{campaign-id}'

Body: { "status": "PAUSED" }

Response 200 OK

{
    "message": "Campaign status changed."
}

 

 

  • Was this article helpful?