8x8 Agent Console and 8x8 Work Integration Users Receive a Blank Screen at Login
Symptom
While attempting to log into 8x8 Agent Console or 8x8 Work integrations, users are presented with a blank screen.
Upon launching the Chrome Developer Tools (F12) and replicating the issue, a "500 Internal Server Error" is presented in the Console log.
Applies To
- Contact Center
- 8x8 Work Integrations v2.x through v3.1
- Integration login
- Google Chrome v80
Resolution
Our engineering team is currently working to permanently resolve this issue. In the meantime, the only workaround is to change your G Suite Policy and rollback Google Chrome to version 79. Follow Rollback Chrome Browser to a previous version to do so.
Cause
The cause of this issue is Google's recent update of the Chrome web browser to version 80.
Specifically, Chrome version 80 now enforces the SameSite secure cookie feature, which disables third-party cookies and prevents cross-domain or third party access (8x8) to the primary domain (such as Salesforce).