Salesforce Lightning Log In Error SSO Failed
Symptom
Error "SSO failed" when attempting to log into Salesforce Lightning through SSO.
Applies To
- 8x8 Contact Center
- Salesforce Lightning
Resolution
Using https://vcc-naX.8x8.com/AGUI/login.php?tenant=%tenantname% in the CTI Adaptor setting allows logins manually to work.
- Log into Salesforce as the Administrator.
- Select Setup > Customize > Call Center > Call Centers.
- Click Edit for 8x8 Virtual Call Center Lightning.
- Change the CTI Adaptor URL to: https://vcc-naX.8x8.com/AGUI/login.php?tenant=%tenantname%
- Where X is your tenant's VCC cluster, and %tenantname% is your tenant's name.
- Click Save.
When your agents log in they will be prompted to enter their Agent credentials when they launch 8x8 Contact Center from Salesforce.
Cause
For Contact Center customers with Mode 1 tenant, SSO is not supported. The CTI for a Mode 1 tenant cannot use the SSO URL: https://vcc-naX.8x8.com/AGUI/loginSSO2.php?tenant=%tenantname% .
Additional Information
For more details, click here.