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Privileges Error Appears in Virtual Office for Salesforce Integration
8x8 Support

Privileges Error Appears in Virtual Office for Salesforce Integration

Symptom

When a Salesforce admin logs into Salesforce as another user, the Virtual Office integration communication panel does not appear, and the following error is displayed:

  • Insufficient Privileges
    You do not have the level of access necessary to perform the operation you requested. Please contact the owner of the record or your administrator if access is necessary. For more information, see Insufficient Privileges Errors.

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Applies To

  • This issue applies to Virtual Office for Salesforce Integration versions 2.8 and 3.1
  • Both Salesforce Classic and Lightning modes

Cause

This issue is caused when:

  1. The Virtual Office for Salesforce Integration versions 2.8 is installed in Salesforce.
  2. The user is assigned to the 8x8 Virtual Office Integration call center, and the variable Enable Salesforce SSO set to true.
  3. A Salesforce administrator logs in as the user through Setup > Manage Users > Users.

OR:

  1. The Virtual Office for Salesforce Integration versions 3.1 is installed in Salesforce.
  2. The user is assigned to the 8x8 Virtual Office Integration call center, with or without SSO enabled.
  3. A Salesforce administrator logs in as the user through Setup > Manage Users > Users.

Resolution

The Virtual Office for Salesforce Integrations are not designed to allow for this kind of administrative login. There are no current plans to address this issue.

In this case, administrators should test their own logins to the 8x8 integrations, and allow users to confirm this functionality on their own logins.

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