Voice for Teams: Sync Errors: Missing SBC domains cause multiple errors to appear in the Teams sync log
Symptom
When a Sync Now process is run in the Voice for Teams admin portal, the following symptoms persistently occur:
- A red warning Sync Now button is displayed.
- Your latest sync logs are marked with the status: Failed
- Multiple different errors appear in the latest Teams sync log.
- The Tenant Setup / Domain Validation section does not appear in your Teams sync logs.
- The dial pad may not appear in Microsoft Teams, and Teams users will not be able to make or receive phone calls.
Applies To
- 8x8 Voice for Microsoft Teams
- Voice for Teams admin portal
- Sync Now
Cause
During the initial service setup phase in the Voice for Teams admin portal, 8x8 SBC domains were not generated and activated in the Microsoft 365 admin center in Settings > Domains.
The Sync Now process always tests for the following, and many of these validation tests will generate errors when run if the 8x8 SBC domains have not been created. In this case, the Tenant Setup / Domain Validation section of the sync log will not appear:
- Get-CsTenantDialPlan
- Get-CsTeamsCallingPolicy
- Get-CsOnlinePstnUsage
- Get-CsOnlineVoiceRoutingPolicy
- Tenant Setup / Domain Validation
- Get-CsTenant
- Get-CsOnlineApplicationInstance
- Users are polled in the Microsoft tenant
- Get-CsOnlineVoiceRoute