Users Bulk Upload Error: Failed to allocate Did from DMS service
Symptom
Virtual Office Configuration Manager > Users Bulk Upload for Switzerland with numbers to be ported gets error:
"failed.voice.allocateVoConfigDid:Failed to allocate Did from DMS service."
Replication Steps
- Log into VO Configuration Manager.
- Select Users.
- Click Bulk Upload > the User Bulk Upload dialog opens.
- Click Download .CSV template.
- Select the fields > click Download template.
- Fill in the template with valid Switzerland contact names, phone numbers, devices, and 8x8 licenses specified.
- In the User Bulk Upload dialog, Drop or Browse to upload the filled in template.
- Click Validate & process.
- Receive messages:
- Validation: UserValidateStatus = success
- Process: "failed.voice.allocateVoConfigDid:Failed to allocate Did from DMS service."
The user(s) is added, but the user has no DID number.
- Click Home > Users > Edit user (pencil icon to the right).
- Go to Voice Basic Settings. You'll see that:
- Phone Numbers is blank
- Device is added, but noted "This device has not been activated"
Applies To
- Virtual Office Configuration Manager
- Bulk Upload
Resolution
Use an 8x8 license for Switzerland, such as Virtual Office X5 Edition-VOSVC0202-CH - "CH" is the country code for Switzerland.
Note: If you do not have 8x8 licenses for Switzerland, contact your 8x8 Account Manager, or call the main 8x8 Sales team phone: 866-879-8647
Cause
The 8x8 license is not for Switzerland.
Example: Virtual Office X5 Edition-VOSVC0202-CA - "CA" is the country code for Canada.
Additional Information
Switzerland is a country that requires additional information to get 8x8 licenses.
To find out other countries with special requirements, please create a case with 8x8 Technical Support. Or, contact your 8x8 Account Manager.