Internal Calls Not Being Received on 8x8 Work for Mobile
Symptom
Users on Work for Mobile (Android) miss all internal calls.
Applies To
- Work for Mobile
- USA
- Verizon
- Google Pixel Phones
- Internal Calls
Resolution
Disable Android Caller ID & spam settings to receive internal calls.
- Tap the Phone application.
- Tap More (three vertical dots, top right) > Settings.
- Near the bottom of the list, tap Caller ID & spam.
- Toggle the Caller ID & spam setting.
Cause
There's a new Call Screening capability, from specific carriers, that incorrectly treats shorter caller IDs (i.e. extension number) as spam calls.