No Unique User Found for the SAML Authenticated User
Symptom
You cannot log in to the 8x8 Work for Desktop or Mobile app using SSO. You receive an error that reads, ''No unique user found for the SAML authenticated user [Username]."
Applies To
- 8x8 Work for Desktop
- 8x8 Work for Mobile
Resolution
The Federation ID needs to be unique.
- Log in to Admin Console.
- Select Users and edit the affected user profile.
- Scroll to Single Sign-On (SSO) and edit the Federation ID with the SSO username so that it is unique. Based on the PBX which is not in use, either one can be deleted, if not federation ID can be removed.
Cause
This issue occurs when the same Federation ID is associated with multiple profiles, which causes a conflict.