Skip to main content

 

 
8x8 Support

Ring Group Caller ID Does Not Show the Caller's Name

Symptom

When receiving a call in a Ring Group, the incoming Caller ID only shows the caller's phone number. The caller's name does not display.

Applies To

  • 8x8 Admin Console
  • Ring Groups
  • Call Queues
  • Caller ID

Resolution

  1. Check the Ring Group Caller ID settings to ensure it is set to Caller's Name and Caller's Number.
  2. If the setting is correct but the issue still occurs, create a case with 8x8 Technical Support.

Cause

A backend setting is preventing Caller ID name from being passed.