I can't upgrade to the latest version of the 8x8 Work for Desktop app
Symptom
When a new version of the 8x8 Work for Desktop app becomes available, my app does not immediately auto-update the same day. If I try using Check for updates, I am provided the previous version, or I see a message that I am already up to date.
Can't see the Check for updates option in Work for Desktop? Click here to learn why.
Applies To
- Work for Desktop (EXE version)
Note: This information does not apply to users whose companies manage their software updates.
Resolution
In-app updates to the Work for Desktop application are rolled out gradually through our installed user base. Users can either:
- Simply wait for the prompt to update. Barring any issues, new version rollouts typically complete within one week.
- Manually download and install the latest version from the page Download Work for Desktop.
Cause
Beginning with Work for Desktop v 7.3, in-app distribution of new releases is handled in a controlled and gradual manner, over the course of one week. This allows 8x8 to better manage the process and ensure the best user experience.