Unable to Log in Using Google Single Sign-On
Symptom
When trying to sign in to Work for Desktop using Google SSO an error appears saying "This browser or app may not be secure"
Applies To
- Work for Desktop 6.5 and older
- Google SSO
Resolution
The issue is resolved in Work for Desktop 6.6 and later. Click to download the latest version of Work for Desktop.
Cause
In December 2019, Google made a change that caused certain accounts to have issues logging in to applications when using their Google accounts for authentication.