8x8 Contact Center Script is not capturing digit presses correctly
Symptom
When calling into a Contact Center script, the digit being pressed will sometimes fail to navigate to the correct option. The audio will be interrupted, but the script will navigate to the empty option instead of the corresponding digit option.
Applies To
- Contact Center
Resolution
Make sure that any interruptible Say or Play objects are directly above their corresponding Get Digit or Menu objects in the script.
Cause
Interruptible Say or Play objects will only pass on the captured digit to the next object in the script. Even if the subsequent object is a non-action object such as a Label, the captured digit will be lost after the next object.