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8x8 Support

Test condition of a queue inside a queue causes call drops

Symptom

Once in a queue the call drops after ringing the agent when it tries to test the condition of the queue at the same time. 

The script looks like this when they have this set:

clipboard_ea23f364bebc1180511445c97c1cfa578.png

Customer Experience shows these 2 things happening at once
clipboard_e19403a7abcafc3bee7a3cf92c7eb8285.png

Applies To

  • Contact Center

Resolution

Remove the test condition of the queue from inside the forward to queue object. 

Cause

The Test condition of the queue was never designed to be used inside a queue. It causes a race condition causing issues when it tests the queue at the same time as presenting to an agent resulting in the call being dropped

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