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Campaign Manager Internal Issue Error caused by a CRM field name with over 26 characters

Symptom

Campaign Manager Internal Issue Error shows when attempting to run a campaign

campaign manager internal issue.png

Applies To

  • Contact Center campaigns

Resolution

  1. Login to Contact Center Configuration Manager for Contact Center
  2. Go to the Outbound Setup, CRM Objects page
  3. Check which CRM fields are enabled in the outbound setup
  4. Go to the CRM, Fields page
  5. Locate any fields that are enabled that have more than 26 characters in the field name

Configuration Manager CRM fields.png

  1. Edit the field
  2. Shorten the field name to be 26 characters or less
  3. Click Save

Configuration Manager CRM edit a custom field.png

  1. Go to the Outbound Setup, CRM Objects page
  2. Delete the edited field
  3. Add the field back (if required)
  4. Click Apply

Configuration Manager outbound setup crm feilds delete.png

  1. Go to the Campaigns page
  2. Start the campaign

Configuration Manager campaign manual running.png

Cause

This error can be caused by having a CRM Field enabled in the outbound setup where the CRM field name is more than 26 characters long.

Additional Information

Campaign Manager Internal Issue Error is a generic error and may show due to other causes