Campaign Manager Internal Issue Error caused by a CRM field name with over 26 characters
Symptom
Campaign Manager Internal Issue Error shows when attempting to run a campaign
Applies To
- Contact Center campaigns
Resolution
- Login to Contact Center Configuration Manager for Contact Center
- Go to the Outbound Setup, CRM Objects page
- Check which CRM fields are enabled in the outbound setup
- Go to the CRM, Fields page
- Locate any fields that are enabled that have more than 26 characters in the field name
- Edit the field
- Shorten the field name to be 26 characters or less
- Click Save
- Go to the Outbound Setup, CRM Objects page
- Delete the edited field
- Add the field back (if required)
- Click Apply
- Go to the Campaigns page
- Start the campaign
Cause
This error can be caused by having a CRM Field enabled in the outbound setup where the CRM field name is more than 26 characters long.
Additional Information
Campaign Manager Internal Issue Error is a generic error and may show due to other causes