No Email Address Results Error in CRM API
Symptom
CRM API using the GET Action to search for customers by <EMAIL> does not return any results when the query value is in all caps characters.
Example, if the email is stored in the CRM 'testemail@testmail.com', this does not retrieve data:
<WAPI>
<tenant> </tenant>
<username> </username>
<password></password>
<command object="Customer" action="get">
<EMAIL>TESTEMAIL@TESTMAIL.COM</EMAIL>
</command>
</WAPI>
Applies To
- 8x8 Contact Center
- CRM API
Resolution
Enter the email address value in the same case as it is stored in 8x8 Contact Center CRM API.
Cause
The Contact Center CRM API is case sensitive when using the GET Action to search.
Additional Information
For more information, see the CRM API User Guide.