Skip to main content
 
8x8 Support

CRM Contact Center Integration Stuck on Reconnecting Error

Symptom

When using a CRM Contact Center integration, you receive an error that reads, "Reconnecting to Salesforce..."

 Screenshot_22.jpg

Applies To

  • Salesforce
  • HubSpot
  • ZenDesk
  • NetSuite
  • Contact Center Integration

Resolution

To by pass the Third Party Storage issue, this flag will have to be disabled within the browser.

Chrome

  1. Go to chrome://flags/#third-party-storage-partitioning.
  2. Search for "Experimental third-party storage partitioning."
  3. Set the flag to disabled.
  4. Relaunch the browser.
  5. Clear cache and continue to log in Salesforce again.

Firefox

  1. Got to about:config.
  2. Set privacy.partition.always_partition_third_party_non_cookie_storage to false.
  3. Clear cache and continue to log in to Salesforce again.

Edge

  1. Go to edge://flags/#third-party-storage-partitioning.
  2. Search for "Experimental third-party storage partitioning."
  3. Set the flag to disabled.
  4. Relaunch the browser.
  5. Clear cache and continue to log in to Salesforce again.

Cause

Following a recent update to the Google Chrome browser 116.0.5845.82, released 09 August 2023, this update changed the way that browsers handle storage partitioning. To prevent certain types of side-channel cross-site tracking, Chrome is partitioning storage and communications APIs in third-party contexts. This change is known to have introduced issues where users are experiencing multiple integration windows popping up and integration panels being stuck on the reconnecting to Salesforce message.

Additional Information

For more information, see Chrome's documentation on Storage Partitioning.

  • Was this article helpful?