Skip to main content

 

 
8x8 Support

Unable to Provision Yealink Phone Due to Certificate Error

Symptom

Yealink phone does not provision. Syslog shows "Certificate doesn't verify" when connecting to ylcfg.8x8.com.

Applies To

  • Yealink phones

Resolution

Caution-Icon.png

While this method is a short-term solution, it can cause problems. All Yealink devices must have a device install certificate; else, further problems will occur.We need to talk about how to make it fault-tolerant.

  1. In a web browser on a computer on the same network as the phone, browse to the phone's IP address.
  2. Log in as admin and enter the password admin. (assuming the phone has been factory reset).
  3. Navigate to Security > Trusted Certificates.YealinkCertificateTrusted.png
  4. Set Only Accept Trusted Certificates to Disabled.
  5. Retry provisioning the phone.

Cause

Some phones will be missing trusted certificates. This causes issues where the phone does not trust the provisioning server. Removing the limitation of only accepting trusted certificates allows the phone to trust the provisioning server.

  • Was this article helpful?