Skip to main content
Re-enter Payment Information with 8x8 Express
8x8 Support

Re-enter Payment Information with 8x8 Express

Symptom

During the 8x8 Express signup process, after entering their payment information, users may be asked to reenter and submit their payment information.

Applies To

  • 8x8 Express

Resolution

  1. Double check to make sure the payment information you have entered is correct and resubmit.
  2. Your credit card may have been declined. Contact your credit card provider.

Cause

There are two possible causes for the error.

  1. Credit card information that was entered was incorrect and therefore declined.
  2. Your credit card was declined by your provider.
  • Was this article helpful?