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My Caller ID Appears as Anonymous on Outbound Calls
8x8 Support Knowledge Base

My Caller ID Appears as Anonymous on Outbound Calls

Problem

When you make outbound calls Anonymous is displayed on the recipient's phone instead of your name and number.

Cause

Your caller ID will show up as Anonymous when your outbound caller ID is blocked. Most often, this occurs on Cisco phones when caller ID has been blocked using the phone's local settings. However, your caller ID can also be blocked in Virtual Office Configuration Manager, Account Manager, or Virtual Office Desktop

Resolution(s)

Cisco SPA 303G or 504G

This setting can only be viewed from the phone's local menu, so you need to change your caller ID settings directly on your desk phone.

To turn off Caller ID Blocking on a Cisco SPA 303G/504G phone:

  1. Press the Setup button.
  2. Scroll down to Preferences and press Select.
  3. Scroll down to Block Caller ID and select Edit. If Yes is listed next to this field, your caller ID is being blocked through your phone's local settings.
  4. Press the Y/N key to choose No.
  5. Press Ok.
  6. Press Save.
  7. Make a test call to ensure that your external caller ID is no longer blocked.

Cisco SPA 525G

This setting can only be viewed from the phone's local menu, so you need to change your caller ID settings directly on your desk phone.

To turn off Caller ID Blocking on a Cisco 525G phone:

  1. Press the Menu button.
  2. Select User Preferences.
  3. Select Call Preferences.
  4. Scroll until you see Block Caller ID.
  5. Use the left-right arrows on the phone uncheck this field.
  6. Press Set.
  7. Make a test call to ensure that your external caller ID is no longer blocked.

Account Manager

Your 8x8 system administrator can check the affected user's caller ID settings and turn off caller ID blocking for individual extension users in Account Manager.

To turn off Permanent Caller ID Blocking in Account Manager:

  1. Log in to Account Manager.
  2. Click Phone System.
  3. Click View.
  4. Under View All Extensions, click View.
  5. Click Edit next to the extension you want to edit.
  6. Under Extension Settings, uncheck the box next to Permanent Caller ID Blocking.
  7. Click Save Changes.

    CIDBLOCK1.PNG
     
  8. Make a test call to ensure that your external caller ID is no longer blocked.

Virtual Office Configuration Manager

Your system administrator can check your caller ID settings and turn off Caller ID blocking for the affected users in Virtual Office Configuration Manager. 

To turn off Caller ID Blocking in Virtual Office Configuration Manager:

  1. Log in to VO Configuration Manager.
  2. Click Users.
  3. Click More Options (three dots) to the right of the user profile that you wish to modify.
  4. Select Edit from the pop-up menu.

    CM - Edit User Profile.jpg
     
  5. Click Advanced Settings.
  6. Click the toggle next to Block External Caller ID to remove your outbound caller ID information. When the toggle turns grey, the block feature is disabled. 
  7. Click Save.
  8. Make a test call to ensure that your external caller ID is no longer blocked.

Virtual Office Desktop

Check Virtual Office Desktop to see if your caller ID has been blocked. 

This is currently available in Virtual Office Desktop's Classic Mode.

To turn off Caller ID Blocking in Virtual Office Desktop:

  1. Click Settings (gear icon), or navigate to Virtual Office > Settings.
  2. Click My Services.
  3. Under External Caller ID, select your number from the Caller ID drop-down.
  4. Click Save.

    CM- Block External CID in VOD Classic Mode-562x419.png

Virtual Office Desktop (Editions End Users)

You can check your caller ID settings and turn off Caller ID blocking in Virtual Office Desktop.

To turn off Caller ID Blocking in Virtual Office Desktop:

  1. Click More Options.
  2. Select Settings.
  3. Select Account Settings.

    VOD- Editions_Settings to Account Settings-400x432.png
     
  4. Click Advanced Account Settings.
  5. Click the toggle next to Block External Caller ID to remove your outbound caller ID information. When the toggle turns grey, the block feature is disabled. 
  6. Click Save.
  7. Make a test call to ensure that your external caller ID is no longer blocked.