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Can't Import CRM Data with CSV in Virtual Contact Center
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Can't Import CRM Data with CSV in Virtual Contact Center

Symptom

Importing CRM data via CSV file in Virtual Contact Center fails. (Particularly affects users without Excel, using a Mac, etc.)

Applies To

Virtual Contact Center

Resolution

Windows

Bulk reformat troublesome data strings in Windows

  1. Open CSV file in Notepad++ (Download http://notepad-plus-plus.org/download/v6.5.5.html).
  2. Perform Search and Replace function.
  3. Find:  \r
  4. Replace with:  \r\n
  5. Click Replace All.
  6. Save.
    VCC_CRM_IMPORT_2-500x216.png

Mac

Bulk reformat troublesome data strings in Mac OS

  1. Open CSV file in TextWrangler (Download http://www.barebones.com/products/textwrangler/download.html).
  2. Click Search > Find.
  3. Select the Group checkbox.
  4. Type:  \r
  5. Replace with:  \r\n
  6. Save.

Cause

Currently, VCC only accepts Windows-style "newlines." (In programming, this means CR, LF—Carriage Return, Line Feed—as common "unix-style" types of carriage return. CR, LF is the native method for Windows.)

For Mac users, the VCC CRM import fails due to Mac not appending a CR, LF for each row of data.

VCC_CRM_IMPORT_1-500x224.png

Note: Notepad++ used to show all characters.

See also:

 

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