Unable to Import CRM Data with CSV in 8x8 Contact Center
Symptom
Importing CRM data via CSV file in 8x8 Contact Center fails. (Particularly affects users without Excel, using a Mac, etc.)
Applies To
- 8x8 Contact Center
- CRM Data
Resolution
Bulk reformat troublesome data strings in Windows and/or Mac OS.
Windows
- Open CSV file in Notepad++ (To download Notepad++, click here).
- Perform Search and Replace function.
- Find: \r
- Replace with: \r\n
- Click Replace All.
- Save.
Mac
- Open CSV file in TextWrangler (to download TextWrangler, click here).
- Click Search > Find.
- Select the Group checkbox.
- Type: \r
- Replace with: \r\n
- Save.
Cause
Currently, 8x8 Contact Center only accepts Windows-style "newlines." (In programming, this means CR, LF—Carriage Return, Line Feed—as common "unix-style" types of carriage return. CR, LF is the native method for Windows.)
For Mac users, the Contact Cennter CRM import fails due to Mac not appending a CR, LF for each row of data.
Note: Notepad++ used to show all characters.