Virtual Office for Salesforce Integration Login Failure
Symptom
When an user attempts to log in to a Virtual Office (web-based) integration using their 8x8 extension credentials, their communication panel session may terminate. This can happen immediately after logging in, or after a browser screen refresh.
In this situation, the user would be shown a list of extensions associated with their user profile after logging in. Selecting any of those extensions will lead to the user being logged out of the communication panel.
Applies To
This issue and the resolution below apply to:
- Account Manager-based user profiles, only. Configuration Manager-based user profiles cannot be assigned multiple extensions.
- Account Manager Primary Admin credentials
- Users who have more than one Virtual Office extension assigned to their Virtual Office user profile in Account Manager.
- All 'Next Generation' or v2.x VO integrations:
- VO Salesforce integration v2.8
- VO NetSuite integration v2.2
- VO Zendesk integration v2.2
- All Maestro-based v3.x VO integrations
- Note that Maestro-based integrations will not display an extension selection window, and will just log the user in to an extension for a short time.
Cause
Virtual Office user profiles that are assigned to multiple extensions are not supported in any current web based Virtual Office integration.
Resolution
A separate, unique user profile must be created in Account Manager for each extension that will be accessed in any Virtual Office integration.