Problem

Your wireless Yealink handsets connected to a W52P base display the same ANI on outbound calls (example: 1001, 1002, etc. show the DID for 1001 on outbound calls, even though they're set to display their own DIDs).

Cause

In the Yealink GUI for the W52P base under Account > Number Assignment, the outgoing lines are all set to show Line 1.

Resolution

To set the correct outbound number

  1. On a computer connected to the same network as the phone, log into the W52P GUI using the phone's IP address and MAC password. Note: When logging into the GUI, enter https:// before the IP address, otherwise it won't work.
  2. Set the outgoing lines appropriately.
  3. Click Confirm.