Error in Scheduling a Meeting with the Implementation Team
Symptom
When attempting to select a date and time for an implementation appointment an error message appears.
Applies To
New users scheduling an appointment with an Implementation agent.
Resolution
The time slot selected is no longer available, please refresh the page and select an alternate time.
Cause
Someone else has selected the time prior to you selecting Schedule Meeting, this is most common when selecting the first available slot or selecting commonly booked times 10AM-2PM PST.
Additional Information
For more info on how to schedule your appointment click here.