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CRM API (wapi) Error 310 Operation Denied. Not enough permissions

Symptom

CRM API (wapi) Error 310 Operation Denied. Not enough permissions.

Applies To

  • Contact Center
  • CRM API (wapi)

Resolution

  1. Login to Contact Center Configuration Manager.
  2. Go to the Integration page and the CRM API tab.
  3. Ensure the relevant permissions are selected for the operation you are trying to perform.

8x8_Contact Centre_Configuration_Manager_Intergration_CRM_API_AccessRights.png

  1. Click Save. You should see a message that reads, "Operation completed successfully."
Caution-Icon.png
  • Updating the CRM API Access Rights for the tenant this will affect all integrations using the CRM API.
  • Ensure you do not remove permissions that are in use/required.

Cause

The login parameters are correct however the relevant permissions required for the request are not selected in Configuration Manager.

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