You can use Cellular Assist so that the cellular connection handles the inbound and outbound calls rather than the mobile data. Learn more here.
Symptom
While on a phone call using the 8x8 Work for Mobile app in data mode on a Sprint or Verizon smartphone, a call in to the cell phone's direct phone number (DID) forces the 8x8 Work for Mobile call to drop.
Cause
This is a known issue with older Verizon and Sprint smartphones, which are unable to simultaneously handle cell phone and mobile data activity. These phones are 3G pre-LT/LTE models, typically up to and including those debuting in 2012. This covers Android and iPhone models up to and including the standard iPhone 5.