Skip to main content
What version of Bullhorn is supported with the 8x8 native integration?
8x8 Support

What version of Bullhorn is supported with the 8x8 native integration?

Applies To

  • Bullhorn
  • Virtual Office Integrations

Answer

The Bullhorn native integration is compatible with the versions below:

  • S Experience
  • Bullhorn Novo
  • Was this article helpful?