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Salesforce Error Unable to Obtain Exclusive Access to This Record
8x8 Support

Salesforce Error Unable to Obtain Exclusive Access to This Record

Symptom

While using VCC Salesforce integration, the VCC user gets a pop-up error:

Your CRM vendor has returned am error: "unable to obtain exclusive access to this record."

Applies To

Virtual Contact Center Salesforce integration users 

Resolution

8x8 Engineering has not identified an issue with the VCC Salesforce integration. Please have your Salesforce administrator enable or confirm user permissions within Salesforce for lead or an other entity.  It is also recommended that Windows 7 users get upgraded to Windows 10. 

Cause

This may be related to Salesforce users not having permissions within Salesforce for lead or any other entity. 

Please also review the Salesforce forum article for other possible causes: https://developer.salesforce.com/forums/?id=9060G0000005U1ZQAU