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Yealink T23 IP Phone: Phone Displays No Service
8x8 Support

Yealink T23 IP Phone: Phone Displays No Service

Your Yealink phone LCD display shows the message No Service. There is no dial tone, and you are unable to make or receive calls. Learn how to fix this here.

Symptom

Your Yealink SIP-T23P or SIP-T23G phone LCD display shows the message No Service. There is no dial tone, and you are unable to make or receive calls.

Applies To

Yealink SIP-T23P, YealinkSIP-T23G

Resolution

Troubleshooting

In cases where the phone had been properly working for a long time and is only suddenly afflicted with these error messages, power cycling your network is often able to clear it up.

Other helpful network troubleshooting:

  • Swap out the Ethernet cord connecting the phone to the network for a different one (to see if a faulty cord might be the issue).
  • Is the phone connected to a wall jack? If so, try connecting it directly to a networking device (router or switch).
  • If the phone is connected to a networking device, try plugging it into a different port on the device (to see if a faulty port is the issue).
  • If accessible, review the firewall/router settings and be sure to disable the following:
    • SIP-ALG
    • SPI
    • Firewall

You can also try setting a static IP on the phone, which has been known to help resolve these issues.

Cause

Your phone is unable to successfully register a SIP account with our services.

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