Skip to main content
Microsoft Dynamics: Error occurs when attempting to install the 8x8 integration package
8x8 Support

Microsoft Dynamics: Error occurs when attempting to install the 8x8 integration package

 

Symptom

When attempting to install the 8x8 integration for Microsoft Dynamics 365, you may receive an error message such as:

  • This app can't be installed because its packages aren't compatible with this environment.
  • You don't have permission to install or update this application.

clipboard_e7720180d55cc615b332d4641dfdd33d2.png

clipboard_ead4076d7770ecec0b7d49469b0b2f4a7.png

Applies To

  • 8x8 Integration for Microsoft Dynamics 365
  • Microsoft Dynamics 365
  • 8x8 Work
  • 8x8 Contact Center

Cause

There are two likely causes for these errors:

  1. The Microsoft Dynamics 365 licensing level is Professional, which is currently not supported.
  2. The person attempting to install the 8x8 integration does not have sufficient permission levels in Microsoft 365 to install the 8x8 integration.

Resolution

  1. Confirm that your licensing level for Microsoft Dynamics 365 is Enterprise or higher.
    • Professional-level licensing currently is not supported, but we are working to provide compatibility with it.
    • At this time there is no ETA for a beta or production release to address this.
  2. If the current Microsoft Dynamics 365 licensing is Enterprise or higher, verify that the person installing the integration has sufficient permissions assigned within the Microsoft environment.

Additional Information

Documentation links and a list of Requirements and Limitations for the 8x8 Microsoft Dynamics 365 integration can be found here:

  • Was this article helpful?