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Error or Maintenance Page When Attempting to Contact Support or View Cases
8x8 Support

Error or Maintenance Page When Attempting to Contact Support or View Cases

Symptom

When attempting to access the 8x8 support portal either via the 8x8 Support Knowledge Base, through a link in a case notification email, or when clicking My8x8 from your Application Panel page at https://sso.8x8.com, you encounter one of the following:

Applies To

8x8 Support Portal

Resolution

Call 8x8 Support

This issue has been resolved for secondary admins in Virtual Office Configuration Manager. If you are experiencing this issue, please call 8x8 Support.

Cause

For all 8x8 business service users, this is an intermittent issue typically related username changes and is under investigation. It is correctable with 8x8 Technical Support assistance.

8x8/Packet 8 Residential Customers: Access to the 8x8 Support Portal is not provided on your service. To create a new Support case, please contact 8x8 by phone. When your case is created, you will receive email notifications at the email address on file in your account. You may correspond on cases by replying to those emails.

 

 

 

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